PHP2Shell: websites on WordPress and other PHP software
Two critical flaws in PHP let attackers take over unpatched web servers without logging in. Now confirmed in real attacks.
Who's affected: Any website running on PHP, including WordPress, Joomla, Drupal and Magento, whose server hasn't been updated since 21 October 2026.
What to do: Ask your web host to confirm PHP is patched (8.5.12, 8.4.27, 8.3.36 or 8.2.35 or later). If you can't patch, take the site offline until you can.
What to do